Cómo reparar el error de Node gyp: No se detectó la versión de Xcode o CLT

Cómo reparar el error de Node gyp: No se detectó la versión de Xcode o CLT

En este tutorial, aprenderemos cómo resolver el error gyp del nodo: No se detectó ninguna versión de Xcode o clt en mac os.

Cuando actualiza un node.js o npm a la última versión e intenta instalar un nuevo paquete npm usando npm install package-name comando verá el extraño error como este en su terminal.

No receipt for 'com.apple.pkg.CLTools_Executables' found at "https://reactgo.com/".

No receipt for 'com.apple.pkg.DeveloperToolsCLILeo' found at "https://reactgo.com/".

No receipt for 'com.apple.pkg.DeveloperToolsCLI' found at "https://reactgo.com/".

gyp: No Xcode or CLT version detected!
gyp ERR! configure error
gyp ERR! stack Error: `gyp` failed with exit code: 1
gyp ERR! stack     at ChildProcess.onCpExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:343:16)
gyp ERR! stack     at ChildProcess.emit (events.js:98:17)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (child_process.js:810:12)
gyp ERR! System Darwin 14.0.0
gyp ERR! command "node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /usr/local/lib/node_modules/gulp/node_modules/fsevents
gyp ERR! node -v v13.10.33
gyp ERR! node-gyp -v v5.0.7
gyp ERR! not ok

Para corregir este error, debe reinstalar las herramientas de línea de comandos de Xcode.

  1. Primero, elimine las herramientas de Xcode usando el siguiente comando.
sudo rm -rf $(xcode-select -print-path)

Este comando anterior solicita una contraseña del sistema.

  1. Ahora instale Xcode ejecutando este comando.

Este comando se muestra con una ventana emergente, haga clic en el install y continúe con la instalación.

La descarga e instalación de las herramientas de línea de comandos de Xcode lleva algún tiempo.

xcode está instalando

Una vez instalado correctamente, ahora puede descargar nuevos paquetes npm sin ningún mensaje de error (gyp).

Si quieres conocer otros artículos parecidos a Cómo reparar el error de Node gyp: No se detectó la versión de Xcode o CLT puedes visitar la categoría Tutoriales.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Subir

Esta página web utiliza cookies para analizar de forma anónima y estadística el uso que haces de la web, mejorar los contenidos y tu experiencia de navegación. Para más información accede a la Política de Cookies . Ver mas